User Tools

Site Tools


getting_started:install_old

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

getting_started:install_old [2015/12/09 16:06] (current)
Line 1: Line 1:
 +====== Installation and Setup (old version) ====== 
 +===== Debian Linux/​Ubuntu/​Linux Mint ===== 
 +  - Get applications and libraries from repository of the distribution:​ <​code>#​ apt-get install git make cmake g++</​code>​ 
 +  - (Optional) Install comedilib. Version must be at least 0.10.1! 
 +    - If you're using Debian 7, Ubuntu 12.04/13.10 or Linux Mint 16 you have to build comedilib from source: 
 +      - install necessary tools: <​code>#​ apt-get install autoconf libtool flex bison automake</​code>​ 
 +      - clone repository: <​code>​$ git clone git://​comedi.org/​git/​comedi/​comedilib.git</​code>​ 
 +      - create configuration script: <​code>​$ ./​autogen.sh</​code>​ 
 +      - configure:<​code>​$ ./configure --with-udev-hotplug=/​lib --sysconfdir=/​etc</​code>​ 
 +      - compile: <​code>​$ make</​code>​ 
 +      - install <​code>#​ make install</​code>​ 
 +      - create symbolic link to libcomedi.so.0:​ <​code>#​ ln -s /​usr/​local/​lib/​libcomedi.so.0.10.2 /​lib/​libcomedi.so.0</​code>​ 
 +    - If you're using Ubuntu 14.04 you can use the binary package of the distribution:​ 
 +      - install library package: <​code>#​ apt-get install libcomedi-dev libcomedi0</​code>​ 
 +  - Clone EEROS repository: <​code>​$ git clone https://​github.com/​eeros-project/​eeros-framework.git</​code>​ 
 +  - Install and setup IDE: 
 +    - Install KDevelop: <​code>#​apt-get install kdevelop</​code>​ 
 +    - Start KDevelop 
 +    - Project -> Open/Import Project, select CMakeList.txt -> Finish ​  
 +    - Compile the project pressing the "​Build"​ button (on Kdevelop)  
 +===== Gentoo Linux ===== 
 +  - Install necessary tools: <​code>#​ emerge -av cmake g++ cppunit kdevelop git qtgui qwt</​code>​ 
 +  - See above 
 +  - See above   
 +  - Install an setup IDE: 
 +    - Install KDevelop: <​code>#​ emerge -av kdevelop</​code>​ 
 +    - As above  ​
getting_started/install_old.txt · Last modified: 2015/12/09 16:06 (external edit)