User Tools

Site Tools


getting_started:install_old

Installation and Setup (old version)

Debian Linux/Ubuntu/Linux Mint

  1. Get applications and libraries from repository of the distribution:
    # apt-get install git make cmake g++
  2. (Optional) Install comedilib. Version must be at least 0.10.1!
    1. If you're using Debian 7, Ubuntu 12.04/13.10 or Linux Mint 16 you have to build comedilib from source:
      1. install necessary tools:
        # apt-get install autoconf libtool flex bison automake
      2. clone repository:
        $ git clone git://comedi.org/git/comedi/comedilib.git
      3. create configuration script:
        $ ./autogen.sh
      4. configure:
        $ ./configure --with-udev-hotplug=/lib --sysconfdir=/etc
      5. compile:
        $ make
      6. install
        # make install
      7. create symbolic link to libcomedi.so.0:
        # ln -s /usr/local/lib/libcomedi.so.0.10.2 /lib/libcomedi.so.0
    2. If you're using Ubuntu 14.04 you can use the binary package of the distribution:
      1. install library package:
        # apt-get install libcomedi-dev libcomedi0
  3. Clone EEROS repository:
    $ git clone https://github.com/eeros-project/eeros-framework.git
  4. Install and setup IDE:
    1. Install KDevelop:
      #apt-get install kdevelop
    2. Start KDevelop
    3. Project → Open/Import Project, select CMakeList.txt → Finish
    4. Compile the project pressing the “Build” button (on Kdevelop)

Gentoo Linux

  1. Install necessary tools:
    # emerge -av cmake g++ cppunit kdevelop git qtgui qwt
  2. See above
  3. See above
  4. Install an setup IDE:
    1. Install KDevelop:
      # emerge -av kdevelop
    2. As above
getting_started/install_old.txt · Last modified: 2015/12/09 16:06 (external edit)